#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(https?:\/\/)?(www\.)?(instagram\.com)\/[A-Za-z0-9_.]{1,30}\/?"
Local $sString = "https://www.instagram.com/napevno_tse_kyrylo/" & @CRLF & _
"https://www.instagram.com/napevno_tse_kyrylo" & @CRLF & _
"https://instagram.com/napevno_tse_kyrylo" & @CRLF & _
"http://instagram.com/napevno_tse_kyrylo" & @CRLF & _
"instagram.com/napevno_tse_kyrylo" & @CRLF & _
"" & @CRLF & _
"https://www.instagram.com/napevno_tse_kyryl____._._dsdfgfg" & @CRLF & _
"https://www.instagram.com/na._._pevno_tse_ky___rylo/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")