re = /(https?:\/\/)?(www\.)?(instagram\.com)\/[A-Za-z0-9_.]{1,30}\/?/i
str = 'https://www.instagram.com/napevno_tse_kyrylo/
https://www.instagram.com/napevno_tse_kyrylo
https://instagram.com/napevno_tse_kyrylo
http://instagram.com/napevno_tse_kyrylo
instagram.com/napevno_tse_kyrylo
https://www.instagram.com/napevno_tse_kyryl____._._dsdfgfg
https://www.instagram.com/na._._pevno_tse_ky___rylo/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end