const regex = /(https?:\/\/)?(www\.)?(instagram\.com)\/[A-Za-z0-9_.]{1,30}\/?/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)?(www\\.)?(instagram\\.com)\\\/[A-Za-z0-9_.]{1,30}\\\/?', 'ig')
const str = `https://www.instagram.com/napevno_tse_kyrylo/
https://www.instagram.com/napevno_tse_kyrylo
https://instagram.com/napevno_tse_kyrylo
http://instagram.com/napevno_tse_kyrylo
instagram.com/napevno_tse_kyrylo
https://www.instagram.com/napevno_tse_kyryl____._._dsdfgfg
https://www.instagram.com/na._._pevno_tse_ky___rylo/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}