use strict;
my $str = 'https://www.instagram.com/napevno_tse_kyrylo/
https://www.instagram.com/napevno_tse_kyrylo
https://instagram.com/napevno_tse_kyrylo
http://instagram.com/napevno_tse_kyrylo
instagram.com/napevno_tse_kyrylo
https://www.instagram.com/napevno_tse_kyryl____._._dsdfgfg
https://www.instagram.com/na._._pevno_tse_ky___rylo/
';
my $regex = qr/(https?:\/\/)?(www\.)?(instagram\.com)\/[A-Za-z0-9_.]{1,30}\/?/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}