using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/)?(www\.)?(instagram\.com)\/[A-Za-z0-9_.]{1,30}\/?";
string input = @"https://www.instagram.com/napevno_tse_kyrylo/
https://www.instagram.com/napevno_tse_kyrylo
https://instagram.com/napevno_tse_kyrylo
http://instagram.com/napevno_tse_kyrylo
instagram.com/napevno_tse_kyrylo
https://www.instagram.com/napevno_tse_kyryl____._._dsdfgfg
https://www.instagram.com/na._._pevno_tse_ky___rylo/
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}