import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?(www\\.)?(instagram\\.com)\\/[A-Za-z0-9_.]{1,30}\\/?";
final String string = "https://www.instagram.com/napevno_tse_kyrylo/\n"
+ "https://www.instagram.com/napevno_tse_kyrylo\n"
+ "https://instagram.com/napevno_tse_kyrylo\n"
+ "http://instagram.com/napevno_tse_kyrylo\n"
+ "instagram.com/napevno_tse_kyrylo\n\n"
+ "https://www.instagram.com/napevno_tse_kyryl____._._dsdfgfg\n"
+ "https://www.instagram.com/na._._pevno_tse_ky___rylo/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}