# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(https?:\/\/)?(www\.)?(instagram\.com)\/[A-Za-z0-9_.]{1,30}\/?"
test_str = ("https://www.instagram.com/napevno_tse_kyrylo/\n"
"https://www.instagram.com/napevno_tse_kyrylo\n"
"https://instagram.com/napevno_tse_kyrylo\n"
"http://instagram.com/napevno_tse_kyrylo\n"
"instagram.com/napevno_tse_kyrylo\n\n"
"https://www.instagram.com/napevno_tse_kyryl____._._dsdfgfg\n"
"https://www.instagram.com/na._._pevno_tse_ky___rylo/\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.