package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(https?:\/\/)?(www\.)?(instagram\.com)\/[A-Za-z0-9_.]{1,30}\/?`)
var str = `https://www.instagram.com/napevno_tse_kyrylo/
https://www.instagram.com/napevno_tse_kyrylo
https://instagram.com/napevno_tse_kyrylo
http://instagram.com/napevno_tse_kyrylo
instagram.com/napevno_tse_kyrylo
https://www.instagram.com/napevno_tse_kyryl____._._dsdfgfg
https://www.instagram.com/na._._pevno_tse_ky___rylo/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}