#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:C[AB]|F[DE]|[ABDEG-Z])+$"
Local $sString = "ABCDE" & @CRLF & _
"ACAFE" & @CRLF & _
"FDCBBB" & @CRLF & _
"FEAC doesn't match because nothing after C" & @CRLF & _
"CBYIU"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")