re = /^(?:C[AB]|F[DE]|[ABDEG-Z])+$/m
str = 'ABCDE
ACAFE
FDCBBB
FEAC doesn\'t match because nothing after C
CBYIU'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end