using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:C[AB]|F[DE]|[ABDEG-Z])+$";
string input = @"ABCDE
ACAFE
FDCBBB
FEAC doesn't match because nothing after C
CBYIU";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}