// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:C[AB]|F[DE]|[ABDEG-Z])+$").unwrap();
let string = "ABCDE
ACAFE
FDCBBB
FEAC doesn't match because nothing after C
CBYIU";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}