const regex = new RegExp('^(?:C[AB]|F[DE]|[ABDEG-Z])+$', 'gm')
const str = `ABCDE
ACAFE
FDCBBB
FEAC doesn't match because nothing after C
CBYIU`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}