$re = '/^(?:C[AB]|F[DE]|[ABDEG-Z])+$/m';
$str = 'ABCDE
ACAFE
FDCBBB
FEAC doesn\'t match because nothing after C
CBYIU';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);