package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:C[AB]|F[DE]|[ABDEG-Z])+$`)
var str = `ABCDE
ACAFE
FDCBBB
FEAC doesn't match because nothing after C
CBYIU`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}