import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:C[AB]|F[DE]|[ABDEG-Z])+$";
final String string = "ABCDE\n"
+ "ACAFE\n"
+ "FDCBBB\n"
+ "FEAC doesn't match because nothing after C\n"
+ "CBYIU";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}