# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<([^<>]*\:)?([^<>]*)>)/{\3}/gmi;t' <<< "/<string:name>/<path:id>/
/<name>/<path:id>/ # <--- Why this is not matching /{name}/{id}/
/<string:name>/<id>/"