using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<([^<>]*\:)?([^<>]*)>)";
string substitution = @"{\3}";
string input = @"/<string:name>/<path:id>/
/<name>/<path:id>/ # <--- Why this is not matching /{name}/{id}/
/<string:name>/<id>/";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}