const regex = new RegExp('(<([^<>]*\\:)?([^<>]*)>)', 'gmi')
const str = `/<string:name>/<path:id>/
/<name>/<path:id>/ # <--- Why this is not matching /{name}/{id}/
/<string:name>/<id>/`;
const subst = `{\3}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);