import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<([^<>]*\\:)?([^<>]*)>)";
final String string = "/<string:name>/<path:id>/\n"
+ "/<name>/<path:id>/ # <--- Why this is not matching /{name}/{id}/\n"
+ "/<string:name>/<id>/";
final String subst = "{\\3}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}