re = /(<([^<>]*\:)?([^<>]*)>)/mi
str = '/<string:name>/<path:id>/
/<name>/<path:id>/ # <--- Why this is not matching /{name}/{id}/
/<string:name>/<id>/'
subst = '{\\3}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result