// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(<([^<>]*\:)?([^<>]*)>)").unwrap();
let string = "/<string:name>/<path:id>/
/<name>/<path:id>/ # <--- Why this is not matching /{name}/{id}/
/<string:name>/<id>/";
let substitution = "{\\3}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}