package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(<([^<>]*\:)?([^<>]*)>)`)
var str = `/<string:name>/<path:id>/
/<name>/<path:id>/ # <--- Why this is not matching /{name}/{id}/
/<string:name>/<id>/`
var substitution = "{\3}"
fmt.Println(re.ReplaceAllString(str, substitution))
}