#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(<([^<>]*\:)?([^<>]*)>)"
Local $sString = "/<string:name>/<path:id>/" & @CRLF & _
"/<name>/<path:id>/ # <--- Why this is not matching /{name}/{id}/" & @CRLF & _
"/<string:name>/<id>/"
Local $sSubst = "{\3}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)