using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[._]";
string substitution = @"";
string input = @"Sep04_17.00.37.tif Sep04_17.05.54.tif Sep04_17.08.41.tif
Sep04_17.02.02.tif Sep04_17.07.17.tif
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}