# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[._]"
test_str = ("Sep04_17.00.37.tif Sep04_17.05.54.tif Sep04_17.08.41.tif\n"
"Sep04_17.02.02.tif Sep04_17.07.17.tif\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.