import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[._]";
final String string = "Sep04_17.00.37.tif Sep04_17.05.54.tif Sep04_17.08.41.tif\n"
+ "Sep04_17.02.02.tif Sep04_17.07.17.tif\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}