const regex = /[._]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[._]', 'g')
const str = `Sep04_17.00.37.tif Sep04_17.05.54.tif Sep04_17.08.41.tif
Sep04_17.02.02.tif Sep04_17.07.17.tif
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);