import Foundation
let pattern = #"[._]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Sep04_17.00.37.tif Sep04_17.05.54.tif Sep04_17.08.41.tif
Sep04_17.02.02.tif Sep04_17.07.17.tif
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)