re = /[._]/
str = 'Sep04_17.00.37.tif Sep04_17.05.54.tif Sep04_17.08.41.tif
Sep04_17.02.02.tif Sep04_17.07.17.tif
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result