# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[ \t]+//gm;t' <<< " A new line begins
Another line begins
Here's another"