const regex = /^[ \t]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ \\t]+', 'gm')
const str = ` A new line begins
Another line begins
Here's another`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);