#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[ \t]+"
Local $sString = " A new line begins" & @CRLF & _
"" & @CRLF & _
" Another line begins" & @CRLF & _
" Here's another"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)