use strict;
my $str = ' A new line begins
Another line begins
Here\'s another';
my $regex = qr/^[ \t]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";