package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[ \t]+`)
var str = ` A new line begins
Another line begins
Here's another`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}