import re
regex = re.compile(r"^[ \t]+", flags=re.MULTILINE)
test_str = (" A new line begins\n\n"
" Another line begins\n"
" Here's another")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)