re = /^[ \t]+/m
str = ' A new line begins
Another line begins
Here\'s another'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result