#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[[^]]*#\d{2}\b[^]]*\]"
Local $sString = "12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else] 12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else]." & @CRLF & _
"" & @CRLF & _
"would result in" & @CRLF & _
"" & @CRLF & _
"12345 one two words [2025/02/25] #15 turtles ."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)