using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^]]*#\d{2}\b[^]]*\]";
string substitution = @"";
string input = @"12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else] 12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else].
would result in
12345 one two words [2025/02/25] #15 turtles .";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}