import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[[^]]*#\\d{2}\\b[^]]*\\]";
final String string = "12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else] 12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else].\n\n"
+ "would result in\n\n"
+ "12345 one two words [2025/02/25] #15 turtles .";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}