const regex = new RegExp('\\[[^]]*#\\d{2}\\b[^]]*\\]', 'gm')
const str = `12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else] 12345 one two [#13 west] words [2025/02/25] #15 [#88]turtles [smth #25 else].
would result in
12345 one two words [2025/02/25] #15 turtles .`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);