#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)<a.+href=['"]((:?https?:\/\/(?:www\.)?site\.ru)?(\/?catalog\/.+))['"].+>"
Local $sString = "<a href="catalog/###/###/about.html">About</a>" & @CRLF & _
"<a href="/catalog/###/###/about.html">About</a>" & @CRLF & _
"<a class="go-link" href="http://site.ru/catalog/###/###/about.html">About</a>" & @CRLF & _
"<a href="http://www.site.ru/catalog/###/###/about.html">About</a>" & @CRLF & _
"<a href="https://www.site.ru/catalog/###/###/about.html">About</a>" & @CRLF & _
"<a href="matalog/###/###/about.html">About</a><a href="https://www.site.ru/news/###/###/###/###/SAMASSILKA.html" target="_blank">GOGO</a>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")