const regex = /<a.+href=['"]((:?https?:\/\/(?:www\.)?site\.ru)?(\/?catalog\/.+))['"].+>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.+href=[\'"]((:?https?:\\\/\\\/(?:www\\.)?site\\.ru)?(\\\/?catalog\\\/.+))[\'"].+>', 'gmi')
const str = `<a href="catalog/###/###/about.html">About</a>
<a href="/catalog/###/###/about.html">About</a>
<a class="go-link" href="http://site.ru/catalog/###/###/about.html">About</a>
<a href="http://www.site.ru/catalog/###/###/about.html">About</a>
<a href="https://www.site.ru/catalog/###/###/about.html">About</a>
<a href="matalog/###/###/about.html">About</a><a href="https://www.site.ru/news/###/###/###/###/SAMASSILKA.html" target="_blank">GOGO</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}