use strict;
my $str = '<a href="catalog/###/###/about.html">About</a>
<a href="/catalog/###/###/about.html">About</a>
<a class="go-link" href="http://site.ru/catalog/###/###/about.html">About</a>
<a href="http://www.site.ru/catalog/###/###/about.html">About</a>
<a href="https://www.site.ru/catalog/###/###/about.html">About</a>
<a href="matalog/###/###/about.html">About</a><a href="https://www.site.ru/news/###/###/###/###/SAMASSILKA.html" target="_blank">GOGO</a>
';
my $regex = qr/<a.+href=['"]((:?https?:\/\/(?:www\.)?site\.ru)?(\/?catalog\/.+))['"].+>/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}