package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<a.+href=['"]((:?https?:\/\/(?:www\.)?site\.ru)?(\/?catalog\/.+))['"].+>`)
var str = `<a href="catalog/###/###/about.html">About</a>
<a href="/catalog/###/###/about.html">About</a>
<a class="go-link" href="http://site.ru/catalog/###/###/about.html">About</a>
<a href="http://www.site.ru/catalog/###/###/about.html">About</a>
<a href="https://www.site.ru/catalog/###/###/about.html">About</a>
<a href="matalog/###/###/about.html">About</a><a href="https://www.site.ru/news/###/###/###/###/SAMASSILKA.html" target="_blank">GOGO</a>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}