$re = '/<a.+href=[\'"]((:?https?:\/\/(?:www\.)?site\.ru)?(\/?catalog\/.+))[\'"].+>/mi';
$str = '<a href="catalog/###/###/about.html">About</a>
<a href="/catalog/###/###/about.html">About</a>
<a class="go-link" href="http://site.ru/catalog/###/###/about.html">About</a>
<a href="http://www.site.ru/catalog/###/###/about.html">About</a>
<a href="https://www.site.ru/catalog/###/###/about.html">About</a>
<a href="matalog/###/###/about.html">About</a><a href="https://www.site.ru/news/###/###/###/###/SAMASSILKA.html" target="_blank">GOGO</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);