using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.+href=['""]((:?https?:\/\/(?:www\.)?site\.ru)?(\/?catalog\/.+))['""].+>";
string input = @"<a href=""catalog/###/###/about.html"">About</a>
<a href=""/catalog/###/###/about.html"">About</a>
<a class=""go-link"" href=""http://site.ru/catalog/###/###/about.html"">About</a>
<a href=""http://www.site.ru/catalog/###/###/about.html"">About</a>
<a href=""https://www.site.ru/catalog/###/###/about.html"">About</a>
<a href=""matalog/###/###/about.html"">About</a><a href=""https://www.site.ru/news/###/###/###/###/SAMASSILKA.html"" target=""_blank"">GOGO</a>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}