// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)<a.+href=['"]((:?https?:\/\/(?:www\.)?site\.ru)?(\/?catalog\/.+))['"].+>"#).unwrap();
let string = "<a href=\"catalog/###/###/about.html\">About</a>
<a href=\"/catalog/###/###/about.html\">About</a>
<a class=\"go-link\" href=\"http://site.ru/catalog/###/###/about.html\">About</a>
<a href=\"http://www.site.ru/catalog/###/###/about.html\">About</a>
<a href=\"https://www.site.ru/catalog/###/###/about.html\">About</a>
<a href=\"matalog/###/###/about.html\">About</a><a href=\"https://www.site.ru/news/###/###/###/###/SAMASSILKA.html\" target=\"_blank\">GOGO</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}