import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "eventType\\\":\\\"(?<Status>.*)";
final String string = "{\"severity\":\"INFO\",\"logger\":\"is_lambda_cacm_cust_events\",\"thread\":\"main\",\"message\":{\"msg\":\"{MessageId: 294b3204-86bb-535e-8e15-6717adceafa6}\",\"eventId\":\"2395587\",\"retryCount\":0,\"name\":\"is_lambda_cacm_cust_events\",\"correlationId\":\"2395587\",\"eventType\":\"Client\",\"originator\":\"Lambda\",\"status\":\"Success\"}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}