use strict;
my $str = '{"severity":"INFO","logger":"is_lambda_cacm_cust_events","thread":"main","message":{"msg":"{MessageId: 294b3204-86bb-535e-8e15-6717adceafa6}","eventId":"2395587","retryCount":0,"name":"is_lambda_cacm_cust_events","correlationId":"2395587","eventType":"Client","originator":"Lambda","status":"Success"}}';
my $regex = qr/eventType\":\"(?<Status>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}